[Spread-users] Unable to get the perl module working

Pete Emerson pete at theemersons.org
Fri Jun 27 13:34:17 EDT 2008

I am trying to get the perl module for Spread working.

I have spread-4.0.0 installed with no changes (installed to /usr/local/ 
(bin|sbin|lib) and working properly with spuser.
I have downloaded the Spread-3.17.3_108 perl module.
I made the following changes to the perl Makefile.PL:

$SPLIB_LIB = '-L../.. -L../spread-src-3.17.0/ -L/usr/local/lib' ;
$SPLIB_INCLUDE = '-I ../.. -I ../spread-src-4.0.0/' ;

I ran the make file, made the module and installed it without error.

I then created a simple spread perl script based on the perldoc for  
Spread (join a group, send a message). It's

I get an error message just like this thread in the archives:


Can't load '/usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/ 
auto/Spread/Spread.so' for module Spread: libspread.so: cannot open  
shared object file: No such file or directory at /usr/lib64/ 
perl5/5.8.8/x86_64-linux-thread-multi/DynaLoader.pm line 230.

However, like the message in the archive, all of the files listed in  
the error message above exist.

I've also done the following to try to remedy the situation with no  

1) Tried spread 3.17.4 and 3.17.3
2) Tried to do the same on 32 bit architecture instead of 64 bit
3) Tried to make no changes to the perl Makefile.PL

Any help would be appreciated.


More information about the Spread-users mailing list