[Spread-users] extremely slow spread subnet

Julien Hoffmann jhfelectric at gmail.com
Sun Feb 19 04:20:29 EST 2017

Hi John,

Thank you for your prompt reply.
You will find my spread.conf file attached. 
I am using spread Version 4.04.00 Built 27 may 2014 on the Raspberry Pis.
Same version number is printed out when I run spread-service on the windows 7 PC.
Configuration Hash value is the same on all systems; all using port 4803.

I haven't tried yet to decrease the number of addresses because changing the conf file on all systems takes a long time.
When I was in my previous configuration (56 addresses, it was working fine).
I did try to boot only a few systems instead of all but the problem persists.

Thanks again for any help.

-----Original Message-----
From: John Lane Schultz [mailto:jschultz at spreadconcepts.com] 
Sent: Tuesday, 14 February, 2017 22:39
To: jhfelectric at gmail.com
Cc: spread-users at lists.spread.org
Subject: Re: [Spread-users] extremely slow spread subnet

I can try to replicate that in my environment.  

What version of Spread were you using?  Would you please send me the problematic configuration file too?

Have you tried using fewer addresses and seeing if the problem persists?


John Lane Schultz
Spread Concepts LLC
Cell: 443 838 2200

On Feb 14, 2017, at 8:58 AM, Julien Hoffmann <jhfelectric at gmail.com> wrote:

Hell spread experts,

In my specific configuration, I have 55 Raspberry Pi Linux modules all with spread installed and configured. One windows7 computer on the same network is also configured to use spread and acts as a “server”. The spread.conf files on all systems is identical and defines only IP addresses used – a total of 56.

I am using a home-made software to “drive” messages in the network, but note that my tests/results are the same when using spuser, sptmonitor etc… When broadcasting a message to all modules, the reaction is almost immediate and the server receives acknowledgements from modules within seconds. So all is well, and I am very happy with spread and this configuration which works since 3 years!

Yesterday, I added 23 new Raspberry Pi Linux modules and modified all spread.conf files. But instead of adding only the 23 new IP addresses, I decided to add all subnet available IP addresses, so that next time I add a new machine, there is no need to modify it again. I added only up to 128 IPs as spread cannot use more.

So I have a spread.conf file with 128 defined IP addresses and 78 machines. Suddenly the entire system is extremely slow, the previous processes now take minutes instead of seconds. 

I firstly suspected a wrong configuration or a physical network issue, but no.

Maybe one of you would have an idea about what could go wrong?

Thanks for any help on that matter,



Spread-users mailing list
Spread-users at lists.spread.org

-------------- next part --------------
A non-text attachment was scrubbed...
Name: spread.conf
Type: application/octet-stream
Size: 13640 bytes
Desc: not available
URL: <http://lists.spread.org/pipermail/spread-users/attachments/20170219/f091d079/attachment.obj>

More information about the Spread-users mailing list