[Spread-users] spread cross compiling binary strip error

Jiva Nath Bagale jnbagale at gmail.com
Mon Aug 22 06:32:40 EDT 2011

Hi Veijo,

Thank you for your help. I managed to pass the strip program as you said
and solve the strip error. But unfortunately, the spread binary itself
doesn't work in the target device. I tried copying spread binary inside
the daemon folder (which is not stripped but is MIPS file), inside the
ipkg-install/usr/sbin folder (which is stripped and is MIPS file), and
also inside ipkg-xburst /spread/usr/sbin (which is stripped but has
corrupted section header size and is MIPS file). The spread binary
inside ipkg-xburst folder seem to go through stripping with
"staging_dir/host/bin/sstrip" which seem to cause the corrupted header.
I have passed  /usr/bin/install -c
--strip-program=mipsel-openwrt-linux-uclibc-strip as strip program which
seems to strip spread binary on ipkg-install folder correctly.

I am wondering why the spread binary doesn't work on the taget device. 
The error on target device is this: -ash: spread: not found

But now I have managed to cross compile spread by hand by specifying
cross compiling host during configure. I am using the strip option as
you suggested here well. The spread daemon runs successfully as well.
But I wish to have it as a package by compiling it through the
toolchain. The fact that the spread compiles fine by hand suggests me
that it should work with the toolchain as well.

Any suggestions.

I solved the same problem by setting the --strip-program argument in a
config.cache file.

1) Edit config.cache file and put there
ac_cv_path_install='/usr/bin/install -c --strip-program=<your strip
full path here>'

2) Configure Spread with cache option
./configure --cache-file=config.cache

This should help with the strip problem.


More information about the Spread-users mailing list