[Spread-users] Configure script

John Schultz jschultz at spreadconcepts.com
Mon Nov 8 12:09:09 EST 2010

The best advice I can offer would be to look at the Visual C project files in the win32 subdirectory to get Spread to compile on windows.

I don't think our autoconf scripts were ever designed to work with windows.

If anyone else knows better, please chime in.


John Lane Schultz
Spread Concepts LLC
Phn: 301 830 8100
Cell: 443 838 2200

On Nov 8, 2010, at 11:47 AM, coderalpha wrote:

Thanks John!

I thought that I should try to change it to use autoconf as this seemed to be the correct solution. Instead I took the short route and changed the #define in stdarch_wintel32.h.

However now I get errors on some header files:
defines.h:43:24: error: sys/socket.h: No such file or directory
defines.h:45:30: error: netinet/in_systm.h: No such file or directory
defines.h:46:24: error: netinet/in.h: No such file or directory
defines.h:47:24: error: netinet/ip.h: No such file or directory
defines.h:77:21: error: termios.h: No such file or directory

This I understand is that I should use winsock.h on Windows. Which makes me feel that I'm just digging a hole here. With the previous error the assumption was made that this is a win32 platform, now it isn't. 


---- On Mon, 08 Nov 2010 17:43:06 +0200 John Schultz <jschultz at spreadconcepts.com> wrote ---- 

That is actually an issue with the stdutil library that is used (and built) by Spread. 

The issue is that stdutil does not expect that the autoconf script can be run on a win32 platform, so it doesn't use autoconf and instead it uses that stdarch_wintel32.h file that has "static" declarations of types. The long long type, in particular, may or may not exist depending on your compiler. If it does exist, then you can simply change that #undef to be #define SIZEOF_LONG_LONG 8 and that should fix your issue. Otherwise, you need to change the conditional compile test and definition of stduint64 and stdint64 to the appropriate 64b type of your environment. 


John Lane Schultz 
Spread Concepts LLC 
Phn: 301 830 8100 
Cell: 443 838 2200 

On Nov 8, 2010, at 6:18 AM, coderalpha wrote: 


I'm trying to build spread on Windows with MinGW. When I run the configure script, I see this in the output: 
checking size of long long... 8 
However, when I run make, I get lots of errors of which this is the first one: 
stdarch_wintel32.h:132:4: error: #error No 8 byte integeral type found! 

The header file stdarch_wintel32.h contains the following definition: 

To me it seems that SIZEOF_LONG_LONG should be defined as 8. 

Any ideas? 
Spread-users mailing list 
Spread-users at lists.spread.org 

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3805 bytes
Desc: not available
Url : http://lists.spread.org/pipermail/spread-users/attachments/20101108/accd1f0a/attachment.bin 

More information about the Spread-users mailing list