[Spread-users] Configure script

John Schultz jschultz at spreadconcepts.com
Mon Nov 8 10:43:06 EST 2010

That is actually an issue with the stdutil library that is used (and built) by Spread.  

The issue is that stdutil does not expect that the autoconf script can be run on a win32 platform, so it doesn't use autoconf and instead it uses that stdarch_wintel32.h file that has "static" declarations of types.  The long long type, in particular, may or may not exist depending on your compiler.  If it does exist, then you can simply change that #undef to be #define SIZEOF_LONG_LONG 8 and that should fix your issue.  Otherwise, you need to change the conditional compile test and definition of stduint64 and stdint64 to the appropriate 64b type of your environment.


John Lane Schultz
Spread Concepts LLC
Phn: 301 830 8100
Cell: 443 838 2200

On Nov 8, 2010, at 6:18 AM, coderalpha wrote:


I'm trying to build spread on Windows with MinGW. When I run the configure script, I see this in the output:
      checking size of long long... 8
However, when I run make, I get lots of errors of which this is the first one:
      stdarch_wintel32.h:132:4: error: #error No 8 byte integeral type found!

The header file stdarch_wintel32.h contains the following definition:
      #undef  SIZEOF_LONG_LONG

To me it seems that SIZEOF_LONG_LONG should be defined as 8.

Any ideas?
Spread-users mailing list
Spread-users at lists.spread.org

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3805 bytes
Desc: not available
Url : http://lists.spread.org/pipermail/spread-users/attachments/20101108/30250655/attachment.bin 

More information about the Spread-users mailing list