[Spread-users] A bug in Spread code ?

Bus Mini micraltoo at gmail.com
Tue Jul 4 10:42:43 EDT 2006

Hello everyone,

I have run into a problem, maybe it was a bug in Spread, whether here is
anyone who has encountered the same problem?
It happened like this.

First, I write a small program which is just to test whether Spread code can
embed into my real application , then I can make my application runs as one

In that small program, I just write a main().., in which it just simply call
Spread' main function.

the call stack is


then the program stay in yy_get_next_buffer() can never come out, I tried to
debug, the first time, I find it stay at

*YY_INPUT( (&yy_current_buffer->yy_ch_buf[number_to_move]),
   yy_n_chars, num_to_read );*

I doubt maybe it was something with yyin (a stream to read spread.conffile).

Then after 4 or 5 hours(so I shun down the computer) , I tried a second

the call stack is:

this time I checked yyin, it works well in Conf_init,  but it crash in
yyparse() when I do this fscanf(yyin,"%s", buf).  While I removed that line,
the program stay at  *yy_current_state = yy_next_state*; in *yylex()*

So, I guess maybe there is some places have memory leak. Because there was
so many Globals variable, and the code have little comment, it was really
hard to debug.

Could someone give me some idea?

Thanks for reading my e-mail, You help is very important to me.

Yours sincerely
Mini Bus.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.spread.org/pipermail/spread-users/attachments/20060704/5e764834/attachment.html 

More information about the Spread-users mailing list