[Spread-users] no daemon

Jacob Green jgreen at spreadconcepts.com
Tue Sep 6 07:35:20 EDT 2005

Looks from this output either:
1.  Spread daemon is not running on chanakya. 
2.  Network traffic from Matrix to chanakya is blocked at least on port 4804
and/or 4805.  (Firewall??)  Ports 4804(tcp/ip & udp), 4805(udp) and
4806(udp) need to be open between matrix and chanakya.

Check both of these things and try again.  

Seems to work when you start Spread on Matrix, and run sp_user from Matrix.
However, when you start Spread on Matrix, it indicates that Matrix is the
only daemon in the configuration that can be reached currently from Matrix's
perspective.  (See "Configuration at matrix is:").


-----Original Message-----
From: spread-users-bounces at lists.spread.org
[mailto:spread-users-bounces at lists.spread.org] On Behalf Of Milind Dumbare
Sent: Tuesday, September 06, 2005 3:16 AM
To: John Schultz
Cc: spread-users at lists.spread.org
Subject: Re: [Spread-users] no daemon

problem is bit solved it displaying something more.......

Conf_init: using file: spread.conf
Successfully configured Segment 0 [] with 2 procs:
Finished configuration file.
Conf_init: My name: matrix, id:, port: 4804
Membership id is ( -1062731499, 1125990368)
Configuration at matrix is:
Num Segments 1
        1     4804

now I have tried spuser on different shell its working but still have
some problem as follows

[milind at Matrix spread-src-3.17.3]$ ./spuser -s 4804 at matrix
Spread library version is 3.17.3
User: connected to 4804 at matrix with private group #user#matrix

User Menu:

        j <group> -- join a group
        l <group> -- leave a group

        s <group> -- send a message
        b <group> -- send a burst of messages

        r -- receive a message (stuck)
        p -- poll for a message
        e -- enable asynchonous read (default)
        d -- disable asynchronous read

        q -- quit

User> q

[milind at Matrix spread-src-3.17.3]$ ./spuser -s 4804 at chanakya
Spread library version is 3.17.3
SP_error: (-2) Could not connect. Is Spread running?

[milind at Matrix spread-src-3.17.3]$

why it is not getting connected to chanakya ?

Spread-users mailing list
Spread-users at lists.spread.org

More information about the Spread-users mailing list