[Spread-users] SmartOS / illumos

Dalho PARK dpark at smart-trade.net
Fri May 17 11:00:57 EDT 2013


I solved the problem.

Checked ld man page and option was not correct.
When compiling gcc otiopn with -Wl, to linker, Linker option should be "--whole-archive" not "-whole-archive" for smartos.
Also -no-whole-archive too.
I changed configure file and compile succeed.


Dalho Park

From: Dalho PARK [mailto:dpark at smart-trade.net]
Sent: Thursday, May 16, 2013 6:45 PM
To: spread-users at lists.spread.org
Subject: [Spread-users] SmartOS / illumos


I'm installing Spread to my SmartOS zone which is illumos based os.
During compiling by make, I received that error.
Does someone know how to solve the problem?

Used source package of Spread :spread-src-4.2.0

Glib version : glib2-2.34.3
GCC: gcc -v
Using built-in specs.
Target: x86_64-sun-solaris2.11
Configured with: ../gcc-4.7.2/configure --enable-languages='c go fortran c++' --enable-shared --enable-long-long --with-local-prefix=/opt/local/gcc47 --enable-libssp --enable-threads=posix --with-boot-ldflags='-static-libstdc++ -static-libgcc -Wl,-R/opt/local/lib ' --disable-nls --enable-__cxa_atexit --with-gxx-include-dir=/opt/local/gcc47/include/c++/ --without-gnu-ld --with-ld=/usr/bin/ld --with-gnu-as --with-as=/opt/local/bin/gas --prefix=/opt/local/gcc47 --build=x86_64-sun-solaris2.11 --host=x86_64-sun-solaris2.11 --infodir=/opt/local/gcc47/info --mandir=/opt/local/gcc47/man
Thread model: posix
gcc version 4.7.2 (GCC)

###### Here is error log of make ######
[root at web01 ~/spread-src-4.2.0]# make
for dir in stdutil libspread-util daemon docs libspread examples ; do \
        ( make -C $dir); \
gcc -shared -o libspread.so fl.tlo scatp.tlo sp.tlo  ../stdutil/src/stdarr.lto ../stdutil/src/stdcarr.lto ../stdutil/src/stddll.lto ../stdutil/src/stderror.lto ../stdutil/src/stdfd.lto ../stdutil/src/stdhash.lto ../stdutil/src/stdit.lto ../stdutil/src/stdskl.lto ../stdutil/src/stdthread.lto ../stdutil/src/stdtime.lto ../stdutil/src/stdutil.lto -Wl,-whole-archive ../libspread-util/lib/libspread-util.sa -Wl,-no-whole-archive -lm -lsocket -lnsl  -lposix4 -lthread -lpthread  -Wl,-h,libspread.so.3
ld: fatal: unrecognized option '-w'
ld: fatal: unrecognized option '-n'
ld: warning: output object option (-o, --output) appears more than once, first setting taken
ld: warning: soname option (-h, --soname) appears more than once, first setting taken
ld: fatal: use the -z help option for usage information
collect2: error: ld returned 1 exit status
make[1]: *** [libspread.so] Error 1
make[1]: Leaving directory `/root/spread-src-4.2.0/libspread'
make[1]: Entering directory `/root/spread-src-4.2.0/examples'
gcc -o spuser user.o -rdynamic ../libspread/libspread-core.a -lm -lsocket -lnsl  -ldl
gcc -o spflooder flooder.o -rdynamic  ../libspread/libspread-core.a -lm -lsocket -lnsl  -ldl
gcc -rdynamic -o sptuser user.to  ../libspread/libtspread-core.a -rdynamic -lm -lsocket -lnsl  -ldl -lposix4 -lthread -lpthread  -ldl
gcc -rdynamic -o flush_user fl_user.to ../libspread/libspread.a -lm -lsocket -lnsl  -ldl -lposix4 -lthread -lpthread  -ldl
make[1]: Leaving directory `/root/spread-src-4.2.0/examples'

Also when I tried to type autoconf, I get following error

[root at web01 ~/spread-src-4.2.0]# autoconf
configure.in:84: error: possibly undefined macro: AC_PTHREAD_FREEBSD
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.spread.org/pipermail/spread-users/attachments/20130517/414fe14c/attachment-0001.html 

More information about the Spread-users mailing list