[Spread-users] An unintentional bug in spread daemon 4 releasecandidate for windows

Jacob Green jgreen at spreadconcepts.com
Wed May 24 12:38:08 EDT 2006

Thanks Danish.  Bug has been fixed, and all win32 project files link with
wsock32.lib rather then Ws2_32.lib. 





From: spread-users-bounces at lists.spread.org
[mailto:spread-users-bounces at lists.spread.org] On Behalf Of Danish Ahmed
Sent: Wednesday, May 24, 2006 11:07 AM
To: spread-users at lists.spread.org
Subject: [Spread-users] An unintentional bug in spread daemon 4
releasecandidate for windows


Hi all

I run spread  daemon with following configuration

Spread_Segment {




danish and jaywks are 2 computer names on our LAN.

i always got error:

DL_init_channel: problem in setsockopt to multicast address -368769529

Then i open spread code and debug it. What i saw the following call always
fail in Data_link.c file in DL_init_channel function.

if (setsockopt(chan, IPPROTO_IP, IP_ADD_MEMBERSHIP, (void *)&mreq, 

sizeof(mreq)) < 0) 


Alarm( EXIT, "DL_init_channel: problem in setsockopt to multicast address
%d\n", mcast_address );


Then i was trying to see code carefully and was making some alteration but i
did not find any solution that would worked. As socket option always got
failed so i guessed it is some problem with membership option. So i made
another program( a very simple one ) to check this API and what i saw it too
always failed. Then i searched it and found it is a problem in winsock
library inclusion from the link http://support.microsoft.com/kb/q257460/.

So i changed the import library file according to this article and it


Review all other spread projects source code for socket options and their
conflicts on winsock libraries and correct them if required according to
given link.

Best Regards

Danish Ahmed

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.spread.org/pipermail/spread-users/attachments/20060524/a3008c20/attachment.html 

More information about the Spread-users mailing list