[Spread-users] spread on FREEBSD

David Carroll david.carroll at adsdotcom.co.uk
Sat Oct 25 06:52:39 EDT 2003

Hi Guys,

When I run spread (using "./spread &" from command line) it appears in the
process list, which seems fine (however spread doesn't leave the command
line clear after this command and I have to ^C to get command prompt back,
but as I say it  does appear in the ps). However when I try and run "spuser"
I get;

Spread library version is 3.17.1
SP_error: (-2) Could not connect. Is Spread running?


I can run spmonitor but when I try to monitor the status I get nothing back;

"Monitor> 0

Activate Status

        Enter Proc Name: all
        Enter Proc Name:
Monitor: send status query

Monitor> Monitor: send status query
Monitor: send status query
Monitor: send status query"

also when I look in the logs (logging DebugFlags = { ALL }) there is the
worrying line;

"DL_send: error: Permission denied"

Now my conclusion is that there is some sort of IP multicast block either in
the local firewall (I'm using freebsd /etc/fw/ ... and I HAVE already opened
the default port) or I have put the wrong IP address of the "multicast
address for subnet". Unfortunately my networking knowledge is lacking here,
I hope someone can steer me in the right direction about this.

The mulitcast address, should it be the same as the "defaultrouter" or the
"netmask" or none of the above .. how will I find out the mulitcast address
.. do I even have one ?  If not what can I use as one? I have tried (a.a.a.x
is the correct IP for the network) a.a.a.0, a.a.a.254, a.a.a.b (b is the
server, spread is running on in this instance), a.a.a.255, and!

Also - will spread communicate with servers on the network without the
application running (e.g. wackamole)? I haven't got past spread yet so I
have not even tried to install wackamole. Could this be where I'm slipping
up ?

And one more thing - will the problems above come if you are only running
one Spread deamon. Instead of running spread deamons on both servers, which
I plan to do btw (conf below). The worrying results from this server
(a.a.a.b) are exactly the same on the other server in this network

I apologise for the length and ignorance of this email I hope someone can

Thanks for your greatly needed help,


conf below;
EventLogFile = /var/log/spread.log
DebugFlags = { ALL }
DangerousMonitor = false
RuntimeDir = /home/spread
DaemonUser = spread
DaemonGroup = spread

Spread_Segment  a.a.a.0:4803 {
        web02             a.a.a.b
        web01             a.a.a.c

More information about the Spread-users mailing list