[Spread-users] Final call for CVS testing

Jeremy Hylton jeremy at zope.com
Tue Sep 24 12:03:04 EDT 2002

I just tried a ./configure; make; make install from a fresh CVS

I get a shallow failure on installation.

slothrop:~/src/spread/daemon> make install
./mkinstalldirs /usr/local/bin
make: ./mkinstalldirs: Command not found
make: *** [install-files] Error 127

It looks like the install-files target doesn't have the right path for
mkinstalldirs.  It should be $(srcdir)/buildtools/mkinstalldirs.

I also tried to build from a subdirectory of the source directory.  I
often use this feature for building on multiple platforms or with
multiple configure options.  I hadn't tried it before with the Spread
daemon, so I don't know if it used to work.

slothrop:~/src/spread/daemon/build> ../configure
[looks fine]
slothrop:~/src/spread/daemon/build> make
/bin/sh: docs/SP_connect.3.out: No such file or directory
make: *** [docs/SP_connect.3.out] Error 1

It looks like the code paths are setup to support building in a
separate directory, but the doc targets aren't.


More information about the Spread-users mailing list